collapse


t-72

  • National Champion
  • Country: no
  • Posts: 991
  • Liked: 1560
Suspect embed thing on Tour de Suisse thread
« on: June 17, 2017, 12:35 »
When I try to open our Tour de Suisse thread (on my iPad) this is what I get.



Looks like there's a worm embedded in a ride with gps embed! I don't think I want to open that in outlook, no....

(This page autoloads when I have selected our tour de suisse thread.).
  • ReplyReply
  • « Last Edit: June 17, 2017, 12:53 by t-72, Reason: grammmar! »

    search

    • Grand Tour Winner
    • *
    • Country: de
    • Posts: 9719
    • Liked: 9557
    • Awards: Member of the year 2016Post of the year 2016KeithJamesMC 2016Member of the year 20152012 CQ Ranking Tour GameAvatar of the Year 2013
    I would think it's not a worm but has something to do with a not supported plugin on the iPad. But I can't say for certain of course. Larri or FtP would need to have a look into it - which is unlikely to happen anytime soon I'm afraid
  • ReplyReply
  • "If this is cycling, I am a banana"

    t-72

    • National Champion
    • Country: no
    • Posts: 991
    • Liked: 1560
    I still think it looks like a worm, and anyway I can't read the thread anymore  :(
  • ReplyReply

  • search

    • Grand Tour Winner
    • *
    • Country: de
    • Posts: 9719
    • Liked: 9557
    • Awards: Member of the year 2016Post of the year 2016KeithJamesMC 2016Member of the year 20152012 CQ Ranking Tour GameAvatar of the Year 2013
    and this doesn't happen in any other threads including embedded ridewithgps profiles?
  • ReplyReply

  • t-72

    • National Champion
    • Country: no
    • Posts: 991
    • Liked: 1560
    Never seen it before, never seen it anywhere else not on this forum or elsewhere.

    There's a difference between using a race profile picture from RWGPS and embedding a ride usign their blog widget. I think that is what has been done here.
    1) there shouldn't be any need for embedding any code at all (for us ordinary users) - we do that sometimes here, we have twitter embedding, prodycycingstats embedding and so on. However (I learned from working with this thread) that the default is we can't embed code here.

    Something might have sneaked in the back door, and it might be an idea to take a closer look on anything referenceing rwgps-embeds.com. I would start by deleting/disabling it, as a preventive measure, until it's been checked out.
  • ReplyReply

  • search

    • Grand Tour Winner
    • *
    • Country: de
    • Posts: 9719
    • Liked: 9557
    • Awards: Member of the year 2016Post of the year 2016KeithJamesMC 2016Member of the year 20152012 CQ Ranking Tour GameAvatar of the Year 2013
    there's a button for Ridewithgps embedding, so everyone can use it. It's just a "normal" html code as far as I can see

    Code: [Select]
    <iframe src="//rwgps-embeds.com/routes/19318117/embed" height="500px" width="100%" frameborder="0"></iframe>
    and for whatever reason, your Safari (?) browser tries to open it with Outlook instead of displaying it in the iframe

    JSG has forwarded the topic to FtP though, so he may have a look into it some time.

    I can't promise anything - nor temporarily disable anything - though. There's no one left with enough technical knowledge, all we can do is continue to use the forum the way it works (or not)
  • ReplyReply

  • Flo

    • #1 Alberto Contador fangirl
    • Grand Tour Winner
    • *
    • Country: nl
    • Posts: 8146
    • Liked: 3925
    • Awards: 2017 TDF Prediction ChampKeithJamesMC award 2016Velorooms Trivia Monday Quiz Champion 2015/2016Dish of the Year 2015Member of the year 2015Fan of the year 20152015 Giro Quiz League - 3rd placeNational Championships Predictions Game Winner 2014Fan of the year 2013Best fanboy/girl 2012
    I have no issues opening the thread on desktop or mobile
  • ReplyReply
  • RIP Keith

    Francois the Postman

    • National Champion
    • Country: scotland
    • Posts: 780
    • Liked: 825
    Sorry for the late response, I checked it earlier today on iPhone and iPad and it worked fine at my end, but didn't want to scream all clear until I was home and had a chance to look at it properly.

    The server is clean (our site), the codebase for the embedded widget doesn't hide anything either, it's properly coded.

    Anyone else with the same issue?

    I suspect: either it was an issue that affected GPS MY Ride and their admins have taken care of it already (in which case it should work on your end now t-72), or it is triggered by a setting on your own iPad that prevents the widget from resolving properly.

    I don't think it is an embedded worm trying to hook you, nothing fishy as far as I can see ;)

    If you still have issues t-72, maybe contact an admin at Ride With GPS site and tell them you are having a problem with their widget? If their codebase has issues with certain iPads, they probably are as keen to resolve that as you are to see the rides! Give em browser details (name and version) and the iOS version you have installed, if you do, that will help them.
  • ReplyReply
  • « Last Edit: June 17, 2017, 21:12 by Francois the Postman »

    t-72

    • National Champion
    • Country: no
    • Posts: 991
    • Liked: 1560
    Thanks for looking this up. After seeing no-one else had the problem I recognized that it might me be my iPad that has a problem, looks like a clean wipe and new set up is about time. Maybe try to remove outlook first, to see what happens next.

    The strange effect only happens on what is now page 1 of the thread when using Safari browser, in firefox it seems to work better (in case anyone else should see something strange). The RWGPS widget doesn't display very well on either (when using the ipad), it keeps growing and shrinking moving the whole page up and down a little. 



  • ReplyReply

  •  



    Top
    Back to top